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ChronoLog is a software tool for computer-assisted chronological research in archaeology, available at 

no cost at chrono.ulb.be. Running ChronoLog requires a working Java installation 

(https://www.java.com/ES/download/).  

This user manual succinctly presents the usage of ChronoLog from a practical perspective. For a more 

detailed presentation of the ChronoLog principles, concepts, and data model, see:  

Levy, E. and Geeraerts, G., Pluquet, F., Piasetzky, E. and Fantalkin, A., 

Chronological Networks in Archaeology: a Formalised Scheme. Journal of 

Archaeological Science 127, 2021. 

Part I: The ChronoLog data model 

1. Chronological networks 
ChronoLog enables users to model chronological data in the shape of a network. We define a 

chronological network as an object consisting of three types of data: periods, sequences and 

synchronisms, which are described below. 

a. Periods 
A period is defined as continuous interval of time, without gaps. It is characterized by a start 

date, an end date, and a duration. While these three quantities are clearly correlated (since 

the duration is the difference between the start date and the end date), each of them can be 

set independently in ChronoLog, as complete knowledge on all three parameters is not always 

available. 

Bounds 
ChronoLog allows to encode lower and upper bounds on the start date, end date and duration 

of a period. One can thus encode an earliest start date, a latest start date, an earliest end date, 

a latest end date, a minimum duration and a maximum duration for each period. None of these 

bounds are mandatory. In order to encode a precise date or duration, one should encode an 

identical lower and upper bound. Figure 1 provides an example of a period in ChronoLog: the 

name of the period appears at the top, followed by the start date, the end date and the 

duration. Each one of the latter three parameters is followed by a range, consisting of two 

buttons contained within square brackets. The first button allows to encode a lower bound 

(i.e. a minimum value) and the second one an upper bound (i.e. a maximum value). The given 

example shows a period contained within the range 1200-1300 CE (earliest start date=1200, 

http://chrono.ulb.be/
https://www.java.com/ES/download/
https://doi.org/10.1016/j.jas.2020.105225


latest start date=1300) and having a known duration of 50 years (minimum and maximum 

durations are set to 50). Buttons located on the right side of the arrows express bounds 

computed by the software and will be explained below (see Section 2a). 

 

Figure 1. A period with a start date not earlier than 1200, an end date not later than 1300 and a duration 
of 50 years. The bounds located on the left side of the arrows represent the encoded data. Those on the right side 

of the data are computed by the software. 

 

b. Sequences 
A sequence is defined as a set of periods that are contiguous in time. The end date of a given 

period is identical to the start date of the next period in the sequence. Every period belongs to 

exactly one sequence. Figure 2 provides an example of a sequence in ChronoLog. The sequence 

contains two periods, one of known duration (50 years), the other with bounded duration 

(between 20 and 40 years). The sequence is further known to have started after 1200 CE, and 

to have ended before 1300 CE. 

 

Figure 2. A sequence comprising two periods. The first period starts not earlier than 1200 CE and lasts 30 years. 
The second period ends not later than 1300 and lasts between 20 and 50 years. 

c. Synchronisms 
We define a synchronism as any chronological relation involving two different periods. The 

simplest type of synchronism is the contemporaneity synchronism, defined as two periods A 

and B having at least one unit of time in common. In more formal terms, this synchronism is 

defined as period A not ending before the start of period B, and period B not ending before 



the start of period A. ChronoLog allows users to encode a wide set of possible types of 

synchronisms between periods. The window for choosing a synchronism is shown in Figure 3. 

 

Figure 3. The ChronoLog synchronism chooser dialog, showing all types of synchronisms supported by the software. 

 



2. Operations on chronological networks 

a. Consistency check 
Given a chronological network comprising a set of sequences, periods and bounds, ChronoLog 

checks automatically whether the encoded data are consistent with each other. For example, 

a period taking place before 1200 CE cannot be contemporaneous with a period taking place 

after 1300 CE. The consistency check is automatically launched every time a change is made to 

the network, i.e. every time one adds, modifies or deletes a period, a sequence or a 

synchronism. In case the model is found to be inconsistent, a pop-up dialog informs the user 

that the model is inconsistent, and proposes an explanation as to why it is inconsistent (see 

Figure 4). 

             

Figure 4. An example of a non-consistent model: period A ends not later than 1200, period B starts not earlier than 
1300, yet both periods are linked by a contemporaneity synchronism. 

b. Tightening 
The tightening operation consists in using the encoded bounds and synchronisms in order to 

compute the tightest possible ranges on each start date, end date and duration. These new 

bounds will be called posterior (or computed) bounds. ChronoLog guarantees these bounds to 

optimal in the following sense: no further tightening of the posterior ranges can be obtained 

using the encoded prior data1. In other words, any more precision on the dates and durations 

can only be obtained by adding more data into the system. The computed bounds are shown 

inside each period, after the arrows. Figure 5 provides an example of tightening. 

              

Figure 5. Example of tightening. The values located on the right side of the arrows depict the posterior bounds. All 
of the start dates, end dates and durations have been improved, except the duration of Period B. 

 
1  For a mathematical justification of this statement, see: Gilles Geeraerts, Eythan Levy, and Frédéric Pluquet. 
Models and Algorithms for Chronology, in: Proceedings of The 24th International Symposium on Temporal 
Representation and Reasoning (TIME), 2017. Leibniz International Proceedings in Informatics, Vol. 13, p. 13:1-
13:18. 

https://drops.dagstuhl.de/opus/volltexte/2017/7929/


Part II: User manual 

1. File operations 
 

a. Creating a new model 

A new model is created using File→New or by clicking the  icon. 

b. Opening and closing a model 

A previously saved model file can be opened using File→Open or by clocking the  icon. 

A model can be closed using File→Close. 

c. Saving a model 
A model can be saved into a file (with “.clog” extension) by using File→Save or by clicking the 

 icon. Alternatively, one can use the “Save as” feature, available through File→Save as 

or by clicking the  icon. 

d. Importing and exporting to CSV 
In order to export the computed results (computed ranges) for each date and duration of a 

model, use File→Export results to CSV.  

Exporting the input data of a model (sequences and synchronisms) is done in two steps: one 

needs to export separately the sequences and the synchronisms. Two CSV files are thus 

created. To export the sequences of a model to a CSV file, use File→Export sequences to CSV. 

To export the synchronisms of a model to a CSV file, use File→Export synchronisms to CSV.  

Once exported, the user can edit these files with any CSV editor if he wishes. To reimport them 

into ChronoLog, use File→Import sequences to CSV (for sequences) and File→Import 

synchronisms to CSV (for synchronisms). The sequences file must be imported before the 

synchronisms file. 

For all CSV import and export options, the separator is the semi-colon. 

e. Resetting a model 

The current model can be reset to a blank one using File→Reset or by clicking the  icon. 

f. Exporting the model as an image 
The current model can be exported as an image (png, jpg, gif or bmp) using File→Export as 

image or by clicking the  icon. 



g. Exporting the model to OxCal 
The current model can be exported as an OxCal (see https://c14.arch.ox.ac.uk/oxcal.html) 

Bayesian radiocarbon model using File→Export to OxCal or using the  icon. ChronoLog 

then launches the “OxCal export” dialog (Figure 6) into which users can encode their 

radiocarbon determinations for each ChronoLog period. In addition, the dialog allows the user 

to choose whether to use the input bounds or the ChronoLog computed bounds in the OxCal 

script. ChronoLog then creates a script in the OxCal language  with Bayesian priors equivalent 

to the ChronoLog sequences, bounds and synchronisms. Every ChronoLog period is translated 

to a ChronoLog phase into which the radiocarbon determinations are inserted. Alternatively, 

one can also export one sequence to OxCal, instead of the whole, model, by clicking on the 

“Menu” button  of the sequence toolbar, then choosing “Export sequence to OxCal”. 

For full details on the conversion rules from ChronoLog to OxCal, see Levy et al., From 

Chronological Networks to Bayesian Models: CHRONOLOG as a Front-end to OxCal (to appear).  

 

Figure 6. The “OxCal export” dialog. 

 

2. Inserting sequences into a model 

a. Creating a  new sequence 

A new sequence can be created using Insert→New sequence or by clicking the  button. 

This will launch a dialog asking for the name of the sequence. The new sequence will contain 

only one period. For adding new periods to the sequence, see below. 

b. Inserting a component from the ChronoLog library 
A component can be added  to the current model using Insert→Insert from library or by clicking 

the  button. The component can consist of a single sequence, or a group of sequences, 

https://c14.arch.ox.ac.uk/oxcal.html


with possible synchronisms between them. The component is added to the current model, 

without erasing its current contents. 

c. Inserting a component from a ChronoLog file (clog format) 
A component can be added to the current model using a previously saved “.clog” file (see 

above for instructions on file saving). This can be done using Insert→Insert from file or by 

clicking the  button. The component contained in the file is added to the current model, 

without erasing the model’s current contents. 

d. Inserting a component from a CVS file 
CVS files for sequences and synchronisms exported through File→Export sequences to CSV (for 

sequences) and File→Export synchronisms to CSV (see above) can be inserted in an existing 

model using Insert→Insert sequences from CSV (for sequences) and Insert→Insert 

synchronisms from CSV. The difference between these operations and the former operations 

File→Import sequences from CSV and File→Import synchronisms from CSV is that the latter 

create a new model while the insertion operations add data to the current model. 

3. Editing sequences 

a. Deleting a sequence 

A sequence can be removed from the model by clicking the  button located near the 

sequence name. 

b. Adding a period to a sequence 

A period can be added at the end of a sequence by clicking the  button in the sequence 

toolbar (see Figure 7). 

 

Figure 7. A newly-created sequence, featuring one period. 

 

c. Renaming a sequence 

A sequence can be renamed by clicking the  button in the sequence toolbar. 

Sequence 

toolbar 



d. Hiding a sequence 

A sequence can be hidden by clicking the  button of the sequence toolbar. A hidden 

sequence appears as shaded and has no effect anymore on the model. Neither its periods nor 

its synchronism are taken into consideration when checking the model’s consistency and when 

computing the tightened ranges of dates and durations. Unhiding a sequence is done by 

clicking on the same button. 

e. Saving a sequence to a file   
A sequence can be saved to a “.clog” file in order to be inserted into future models. This is 

done by clicking on the “Menu” button  of the sequence toolbar, then choosing “Save 

sequence”. A saved sequence is saved “as is”, without other sequences and  

synchronisms. 

f. Changing all period durations 
The durations of all periods of a sequence can be changed at once. This is done by clicking on 

the “Menu” button  of the sequence toolbar, then choosing “Set durations”. 

g. Reloading a sequence 
The default values of a sequence can be . This is done by clicking on the “Menu” button 

 of the sequence toolbar, then choosing “Reload”. This only affects the bounds of the 

dates and durations of the sequence’s periods. It has no effect on synchronisms. The default 

values are defined as “unknown” for newly-created sequences, and as the initially loaded ones 

if the sequences was loaded from a library or from a file. 

h. Tagging a sequence 
Each sequence can be assigned a series of tags. In order to add or remove tags from a 

sequence, click on the “Menu” button  of the sequence toolbar, then choose “Tags” 

(see Figure 8). 



 

 

Figure 8. Pop-up dialog showing the two tags (namely “ChronoLand” and “Stratigraphy”) of the sequence 
“ChronoLand strata”. 

i. Hiding/showing sequences according to tags 
The bottom part of the ChronoLog window contains the tags panel. This panel allows the user 

to check/uncheck the desired tags. After clicking on “Select”, all tags that are unchecked are 

hidden from the model, using the same sequence hiding mechanism as described above. The 

effect of this procedure is that each sequence which has at least one unchecked tag becomes 

hidden (even if it does have another that which is not hidden). Figure 9 provides an example 

of hiding a specific tag. 



 

Figure 9. Hiding the “Stratigraphy” tag. This has the effect of automatically hiding the “ChronoLand strata” 
sequence, since this sequence has the “Stratigraphy” tag. 

j. Moving a sequence 
Sequences can be moved by drag and drop, by clicking on the sequence name. 

 

4. Editing periods 

a. Renaming a period 
A period can be renamed by clicking on its name, which launches a pop-up menu asking for 

the new name (see Figure 10). Note that two periods may not have the same name. 

Alternatively, one can click on the  button in the period’s upper right corner, which 

launches a pop-up menu, then click on “Edit name”. 

 

Figure 10. Changing the name of a period. 



b. Deleting a period 

A period can be deleted by clicking on the  button in the period’s upper right corner, 

which launches a pop-up menu, then clicking on “Delete”. Deleting a period removes it from 

its sequences, and removes all its synchronisms from the model. The sequence, and all the 

other periods contained therein,  are not removed however. 

c. Inserting a new period above a given period 
A new period can be inserted above a given period. The new period is thus earlier in time than 

the given period. This is done by clicking on the  button, which launches a pop-up 

menu, then clicking on “Insert above”. 

d. Inserting a new period below a given period 
A new period can be inserted below a given period. The new period is thus later in time than 

the given period. This is done by clicking on the  button, which launches a pop-up 

menu, then clicking on “Insert below”. 

e. Editing a prior bound 
A newly created period has unknown prior bounds for its start date, end date and duration. In 

order to set such a prior bound, one clicks on one of the buttons of the range located left of 

the arrow. This will launch a dialog enabling the user to input a value for the bound, or to set 

it to “unknown”. Figure 11 shows an example of fixing an earliest start date for a period. Fixing 

other types of bounds (latest start date, earliest end date, latest end date, minimum duration 

and maximum duration) is done in the same way. Dates BCE are set using a negation sign, as 

in -1234. Editing a period immediately launches a consistency check of the model, and a 

recomputing of the tightened (posterior) ranges. 

 

Figure 11. Setting an earliest start date of 1200 CE for a period. 

 

f. Consulting traces 
The buttons located at the right side of the arrow sign allow the user to obtain a trace (i.e. a 

justification for a computed (i.e. posterior) bound. This trace is displayed in a separate pop-up 

dialog (see Figure 12). Bounds and synchronisms participating in the trace are highlighted in 

red (except for duration traces). 

 



 

 

Figure 12. Clicking the “1265” button provides a traces for the 1265 computed latest start date of period “Baldwin”. 

 

5. Working with synchronisms 

a. Adding a synchronism 
A synchronism can be added by connecting two periods directly with the mouse, or by using 

the synchronisms panel located at the right side of the ChronoLog window. In both cases, a 

dialog appears asking the user to choose the desired type of synchronism. Each synchronism 

type is provided with a formal definition and an explanatory figure (see Figure 13). Another 

way to connect two periods, especially useful for periods that are far from each other, is to 

click on a period, drag a line and release it in an empty spot. A dialog then appears asking the 

user to choose the destination period (see Figure 14). 

 

 



 

Figure 13. The synchronisms creation dialog. 

 

Figure 14. Creating a synchronism by releasing the mouse in empty space. 



b. Consulting a synchronism 
Each synchronism appears both as an arrow connecting two periods, and as a line in the 

synchronisms panel. Clicking on a synchronisms arrow displays a small pop-up dialog showing 

the full name of the synchronism, and allowing to hide it, modify it or delete it (see Figure 15). 

 

 
Figure 15. Pop-up dialog obtained by clicking on a synchronism. 

c. Deleting a synchronism 
A synchronism can be deleted by clicking on the synchronism’s arrow, then clicking on the 

“Delete” button of the ensuing pop-up dialog (see Figure 15). Alternatively, one can also delete 

the synchronism by clicking on the  button of the synchronisms panel, located on the 

right side of the ChronoLog window. 

d. Hiding a synchronism 
A synchronism can be hidden by clicking on the synchronism’s arrow, then clicking on the 

“Hide” button of the ensuing pop-up dialog (see Figure 15). Alternatively, one can also delete 

the synchronism by clicking on the  button of the synchronisms panel, located on the 

right side of the ChronoLog window. A hidden synchronism is no longer part of the current 

model, and thus is not taken into account when checking the consistency of the model nor in 

computing the tightened bounds. In order to unhide a synchronism, repeat the same 

operation. 

e. Modifying a synchronism 
The type of a synchronism can be modified by clicking on the synchronism’s arrow, then 

clicking on the “Modify” button of the ensuing pop-up dialog (see Figure 15). 



f. Moving a synchronism 
A synchronism’s arrow can be moved by clicking and dragging it with the mouse (see Figure 

16). 

 

Figure 16. Moving the synchronism between “Stratum 2” and “Albert”. 

6. Visual tools 

The model can be zoomed in or out through the buttons  in the main toolbar, or through 

View→Zoom in and View→Zoom out¸ or through the sliding bar located at the bottom right of the 

ChronoLog window. 

 

Part III: Example: the kingdom of ChronoLand 

1. Introduction 
This section presents an artifical example called “ChronoLand”, which represents a simple use case 

with two kings and two archaeological strata, with two synchronisms between kings and strata. The 

purpose of the example is to show that even in such a small data set, computing the optimal 

chronological bounds (as well as performing other types of queries, see below) is not an easy task 

without the aid of a computational tool such as ChronoLog.  

2. Data 
In the Kingdom of ChronoLand, Kings Albert and Baldwin reigned in succession. We do not know their 

precise reign dates, but both reigns are known to have occurred between 1200 and 1300 CE. We also 

know from ancient annals that Albert’s reign did not exceed 10 years, and we know from epigraphic 

sources that Baldwin reigned at least 35 years. Recent excavations at ChronoCity, the capital city of 

ChronoLand, have unearthed two archaeological strata: Stratum 1 and Stratum 2. The earlier stratum, 

Startum 1, was built on bedrock, and contained an in-situ stela of King Albert, claiming he built 

ChronoCity. The latest stratum, Stratum 2, was destroyed by fire in a heavy conflagration. According 

to ancient annals, the city was destroyed during the reign the reign of King Baldwin and was never 

reoccupied. Finally, we assume that each of our strata has a duration of at least 20 years.  



3. Modelling 
Figure 17 and Figure 18 shows the modelling of the ChronoLand data with ChronoLog. 

 

Figure 17. Modelling the ChronoLand data with ChronoLog (full ChronoLog screen). 

 

Figure 18. Modelling the ChronoLand data with ChronoLog (zooming on sequences) 

The bounds located on the right side of the arrows are the result of the tightening operations. Some 

of them are straightforward: the 1265 upper bound on the start of Baldwin stems from the 1300 latest 

end of Baldwin and the 35 years minimum duration of his reign. Others are more tricky, like the 1240 

lower bound on the end of Baldwin’s reign. This bound stems from a longer chain of implications, 

starting from the 1200 lower bound on the start of Albert, going through the 20 years minimum 

duration of Stratum 2 (via the “starts during” synchronism) , the 20 years minimum duration of Stratum 

1, then looping back to Baldwin through the “ends during” synchronism. Figure 19 presents the full 

trace for this computed bound, as obtained by clicking on the “1240” button in ChronoLog. 

 



 

Figure 19. A justification of the computed 1240 lower bound for the end of Baldwin’s reign, as obtained by Chronolog (by 
clickin on the “1240” button). 



4. Querying the model 

a. Detecting inconsistency in a model 
One usage of ChronoLog is to test the global impact of a local change to the chronological 

network. For example, what if Baldwin reigned at most 25 years, instead of at least 35 years? 

In this case, ChronoLog will report that the model is not consistent, as shown in Figure 20. Here 

again, ChronoLog reports automatically the cause of the inconsistency, as shown in Figure 21. 

Here, the cause stems from the fact that the new 25 years upper bound yields a 35 years 

maximum duration for the whole dynasty, which is not enough to encompass the 40 years 

minimum duration (20 + 20 years) of the two strata. 

 

Figure 20. Changing the duration bounds of Baldwin to maximum 25 years yields an inconsistency result. 



 

Figure 21. ChronoLog trace for the inconsistency result when limiting Baldwin’s duration to 25 years (partial view). 

b. Checking the global impact of local changes to the network 
What if we wish to set a realistic upper bound on the reign length of Baldwin. We know he 

reigned at least 35 years, but clearly no king can reign forever. How would a bound of, say, 70 

years on his reign affect the overall chronology? Such questions are not easy to answer without 

a computational tool. ChronoLog’s answer to this question is shown in FIGFGG: the two strata 

get an upper bound of 60 years instead of 80 years. This stems from the fact that the maximum 

duration of the dynasty is now 80 years and that each stratum lasts at least 20 years. Hence 

the other stratum can last at most 80-20 years. 

 

Figure 22. Result of setting an additional 70 years upper bound on Baldwin’s reign. 



 

c. Testing hypotheses 
ChronoLog also allows to test hypotheses. We know for example that stratum 2 was built by 

Albert. But who built stratum 1? The computed date ranges do not provide an answer, since 

stratum  1 starts in the range [1220-1280], which could a priori correspond both to Albert’s 

reign (located within the range [1200-1265]) and Baldwin’s reign (located within the range 

[1200-1300]). Let us therefore test whether it is possible that Albert built stratum 1. We 

therefore add the synchronism “Stratum 1 starts during Albert” to the model. This new 

synchronism yields an inconsistency, detected by ChronoLog: stratum 1 cannot have been built 

by Albert, because this would require the whole of stratum 2 to be included within Albert’s 

reign, which is too short (at most 10 years) to encompass the whole of stratum 2’s duration (at 

least 20 years). We can thus conclude that stratum 1 was built during Baldwin’s reign. This is 

illustrated in Figure 23. 

 

Figure 23. Result of adding the synchronism “Stratum 1 starts during Albert” to the model. ChronoLog detects an 
inconsistency, implying that stratum 1 was built during Baldwin’s reign. 
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